How to list the type of fiber channel card and it’s WWN info in AIX

I needed to find out the type of fiber channel HBA cards installed in the Aix server. Here are the commands I used to find the information,

Use the lsdev command to list the fiber channel cards (HBA) installed in the Aix server. Depending on the version of aix one or all of the commands below should work.

:/root > lsdev -C | grep fcs
fcs0 Available 04-08 FC Adapter
fcs1 Available 07-08 FC Adapter
fcs2 Available 0A-08 FC Adapter
fcs3 Available 0B-08 FC Adapter

OR

:/root > lscfg -vp | grep fcs
fcs2 U787B.001.DNW19B5-P1-C1-T1
FC Adapter
fcs3 U787B.001.DNW19B5-P1-C2-T1
FC Adapter
fcs0 U787B.001.DNW19B5-P1-C3-T1
FC Adapter
fcs1 U787B.001.DNW19B5-P1-C5-T1
FC Adapter

OR

itsm:/root > lsdev -Ccadapter | grep fcs
fcs0 Available 04-08 FC Adapter
fcs1 Available 07-08 FC Adapter
fcs2 Available 0A-08 FC Adapter
fcs3 Available 0B-08 FC Adapter

To find the WWN info for the Fc interface use the lscfg command. The Network Address is the WWN, e.g. Network Address………….10000000C942E65C.
The firmware level is Device Specific.(Z9)……..TS1.91A5.

:/root > lscfg -vl fcs0
fcs0 U787B.001.DNW19B5-P1-C3-T1 FC Adapter

Part Number……………..80P4543
EC Level………………..A
Serial Number……………1F4500AC78
Manufacturer…………….001F
Feature Code/Marketing ID…280B
FRU Number……………… 80P4544
Device Specific.(ZM)……..3
Network Address………….10000000C942E65C
ROS Level and ID…………02881955
Device Specific.(Z0)……..1001206D
Device Specific.(Z1)……..00000000
Device Specific.(Z2)……..00000000
Device Specific.(Z3)……..03000909
Device Specific.(Z4)……..FF801413
Device Specific.(Z5)……..02881955
Device Specific.(Z6)……..06831955
Device Specific.(Z7)……..07831955
Device Specific.(Z8)……..20000000C942E65C
Device Specific.(Z9)……..TS1.91A5
Device Specific.(ZA)……..T1D1.91A5
Device Specific.(ZB)……..T2D1.91A5
Device Specific.(YL)……..U787B.001.DNW19B5-P1-C3-T1

The command lsmcode will display the firmware and microcode level.
:/root > lsmcode -d fcs0

Below is the command to list the fileset.

:/root > lslpp -l | grep “FC Adapter”
devices.pci.77101223.com 5.3.0.51 APPLIED PCI FC Adapter (77101223)
5.3.0.50 APPLIED PCI FC Adapter (77101223)
devices.pci.77101223.rte 5.3.0.10 COMMITTED PCI FC Adapter (77101223)
devices.pci.77102224.com 5.3.0.51 APPLIED PCI-X FC Adapter (77102224)
devices.pci.77102224.diag 5.3.0.0 COMMITTED PCI-X FC Adapter (77102224)
devices.pci.77102224.rte 5.3.0.50 APPLIED PCI-X FC Adapter (77102224)
devices.pci.df1000f7.com 5.3.0.54 APPLIED Common PCI FC Adapter Device
5.3.0.50 APPLIED PCI FC Adapter Device
devices.pci.df1000f7.rte 5.3.0.30 APPLIED PCI FC Adapter Device Software
devices.pci.df1000f9.diag 5.3.0.0 COMMITTED 64-bit PCI FC Adapter Device
devices.pci.df1000f9.rte 5.3.0.30 APPLIED 64-bit PCI FC Adapter Device
devices.pci.df1000fd.rte 5.3.0.50 APPLIED 4Gb PCI-X FC Adapter Device
devices.pci.df1080f9.diag 5.3.0.0 COMMITTED PCI-X FC Adapter Device
devices.pci.df1080f9.rte 5.3.0.30 APPLIED PCI-X FC Adapter Device
devices.pci.77101223.com 5.3.0.0 COMMITTED PCI FC Adapter (77101223)
devices.pci.77102224.com 5.3.0.0 COMMITTED PCI-X FC Adapter (77102224)
devices.pci.df1000f7.com 5.3.0.54 APPLIED Common PCI FC Adapter Device
devices.pci.df1000f7.diag 5.3.0.0 COMMITTED PCI FC Adapter Device
devices.pci.df1000f7.rte 5.3.0.0 COMMITTED PCI FC Adapter Device Software

About Andrew Lin

Hi, I have always wanted to creat a blog site but never had the time. I have been working in Information Technology for over 15 years. I specialize mainly in networks and server technologies and dabble a little with the programming aspects. Andrew Lin

View all posts by Andrew Lin →